Hopp til navigasjon Hopp til innhold
Google setter nye krav til utviklerne. (Ill.: ITavisen)

Mange apper kan slutte å fungere når Android 9 lanseres

Google setter større krav til utviklerne.

Den kommende utgaven av Android går under kodenavnet «Android P» og det er ikke altfor lenge før Google skal avsløre flere detaljer om det kommende operativsystemet.

Appene må oppdateres

Android Police skriver nå at Google innfører nye krav til utviklerne der konsekvensen er at flerfoldige apper slutter å fungere når den nyeste versjonen lanseres. Årsaken er nemlig den at Google setter som krav at utviklerne må bruke et API-nivå som er maksimalt ett år eldre enn den nåværende lanseringen.

Det vil si at utviklerne må lage/oppdatere apper for Android 8.0 eller nyere når «P» lanseres i høst. Google har selv bekreftet at fremtidige Android-versjoner kan komme til å blokkere apper som ikke bruker de nyeste API-nivåene.

Når det gjelder det laveste API-nivået for Android P, er det nivå 17 som tilsvarer Android 4.2, opplyser Android Police.

Android er like sikkert som iOS.

 

Kilde:
Android Police

Stikkord: android, Google, pp