Hopp til navigasjon Hopp til innhold
Du trenger ikke iPhone 4S for å bruke Siri, hevder hackeren Jackoplane. (Ill.: Engadget.com)

Siri for alle?

Krever ikke jailbreak av iPhone 4S, hevder hacker.

Apples nye personlige assistent Siri virker offisielt bare med iPhone 4S.

Men alle apparater som støtter iOS 5 (se listen HER) kan også kjøre Siri.

Dette har vært kjent en stund, men det krever altså såkalt Jailbreak – at u åpner telefonen slik at du kan installere programvare som ikke er forhåndsgodkjent av Apple.

Men selv om du jailbreaker telefonen din, har det hittil vært slik at du ikke oppnår kontakt med Apples Siri-server. Dermed blir funksjonen bare en guttelek, og ikke et brukbart verktøy.

Nå mener imidlertid en hacker som kaller seg Jackoplane at han har klart å knekke Apples kode slik at man verken trenger å jailbreake iPhone 4S eller å ha noen annen tilgang til Apples systemet enn en normal iTunes/iCloud-konto.

Jackoplanes Twitter-konto foregikk det i natt en livlig diskusjon om hacket er reelt eller ikke.

Konkrete bevis kunne ikke Jackoplane legge fram, men han lover at det snart vil foreligge en YuTube-video som dokumenterer hacket i detalj.

Dersom Jackoplane snakker sant, er det gode nyheter for de med en iPhone 4 eller 3GS. Disse telefonene støtter iOS 5, og kan ved hjelp av et slikt hack ta i bruk Siri allerede nå.

Må jailbreakes likevel
De eldre telefonene må imidlertid jailbreakes for at filene skal kunne installeres, ifølge Jackoplane.

Poenget er altså bare at man ikke lenger trenger å jailbreake iPhone 4S for å få aktivert Siri på de eldre telefonene.

Tas seriøst
Hvor sannsynlig dette er, kan vi som sagt ikke si noe bastant om nå.

Men det vanligvis velinformerte jailbreak-nettstedet Cydiahelp.com har snappet opp saken, og ser i hvert fall ut til å behandle saken seriøst.

Stikkord: ios 5, siri